dipper (Mi 8) - stook on 'Boot Partition: None Click more to specify it manually' "If you boot with UEFI, it needs a FAT16/ FAT32 partition'

Hi,my first post on this forum, already with a problem of booting Win11 image from partition created on Mi 8 (NTFS partition).

I was guided by those three sources :

  1. Original project Renage installation guide:

Renegade Project

Renegade Project

renegade-project.org

Renegade Project

Renegade Project

BTW Xiaomi Mi 8 is on supported decives list: Renegade Project

  1. this yt wideo about installing Win 11 on Mi 8 (unfortunately, in Russian and the youtuber is showing some tips too fast, so I had to slow it down to 0.25 in some parts)

Windows 11 на СМАРТФОНЕ - ТЕСТ, УСТАНОВКА

  1. yt tutorial about installing Win 11 on OnePlus 6T
    Dualboot Windows & Android on OnePlus 6T - YouTube

So, I have manage to remove and create userdata partition, I have eacreated smaller userdata partion with 30 GB instead of 100-ish something GB,
I have created also \pe partition for WinPE boot (works from UEFI boot), \win (formatted in NTFS) with about 70-something GB, and ESP partition in FAT32.

The UEFI Boot for Mi 8 (device code: dipper) is not installed on the device, I am booting it by flashing it via fastboot (single time, the normal boot image on the device is still genuine boot.img from Xiaomi).

So, just like in the beforementioned guides / tutorials, I am able to boot WinPe (part English, part Chinese), able to start DISM+, able to open prepared Win11 disk (tried either on whole image or n single .wim file) and then:

  1. I am asked for choosing a disk to install Win11;
  2. I choose \win parttion in NTFS
  3. I see window titled ‘Bootmgr Repair-UEFI’ with a message: 'Boot Partition: None Click more to specify it manually
  4. If I choose NTFS partition, I see windwos titled “Tips” with message "If you boot with UEFI, it needs a FAT16/ FAT32 partition
  5. I choose ESP Partition 3 Things You Should Know about EFI System Partition (ESP), install it, then install drivers; enabling Enable Test-Signing mode and reboot device with shutdown -s -t 0
    After installation I reboot application → no UEFI boot so i go to fastboot mode (by combinatin of buttons) from my PC i flash uefi dipper img i choose pption with Windws Bootloader from UEFI boot option, I am waiting and after a lot of time i see that there was a problem with installation of Windows.

What I am doing wrong here? Any thoughts?

have you added esp flag to your esp?

You forgot to set esp on using parted through twrp
I know that because I did the same
set 21 esp on (21 in my case, check your esp numer using “print” command on parted)
and try again